Slowness when saving patient records in CapacityIQ

Incident Report for TeleTracking IQ6182

Monitoring

The previously reported issue is no longer occurring at this time. Our teams have completed monitoring and verification, and system functionality has returned to normal.
We will continue to monitor the environment closely to ensure stability and will take further action if the issue reoccurs.
Posted Jun 04, 2026 - 18:06 EDT

Investigating

We are currently investigating an issue in CapacityIQ with slowness when updating a patient record.
Posted Jun 04, 2026 - 16:24 EDT
This incident affects: Services (Capacity IQ App).